Results 1 to 9 of 9

Thread: Device Lost Exception Detected : USB 2.0 Cam DMK 31 AU03

  1. #1
    Join Date
    Aug 2012
    Posts
    6

    Device Lost Exception Detected : USB 2.0 Cam DMK 31 AU03

    Using VB.net for the Application. Camera DMK31AU03; PC OS : WIN 7 Professional 32 Bit; PC : HP 280 Commercial Grade Desktop with Core i3/4GB RAM; Cable Active Repeater USB 2.0 Cable with 8m Length.
    While the above parameters are the same Machine to Machine, in few cases, we find there are Issues with Image update. Either there is a Device Lost Exception thrown (OR) the Image freezes requiring restart of the Application. The occurrence is Random and there is no Pattern. USB Root Hub (Allow Windows to Turn-Off) settings are disabled; PC/HDD Sleep disabled; Using USB Camera Drivers 2.8.9; Processor Idle state Manager is installed
    We suspected Cable length of normal USB2.0 Cable and have switched over to Active Repeater. Still issue persists. We need to use 7.5m Cable length for the Machine at minimum.
    Please suggest if any betterment could be done for eliminating this issue.

    Thank you very much
    Best Regards,
    NV Srinivass

  2. #2
    Join Date
    Jan 2003
    Location
    Bremen, Germany
    Posts
    4,886

    Re: Device Lost Exception Detected : USB 2.0 Cam DMK 31 AU03

    Hello Srinivass

    If you have random disconnects, I suggest to narrow down the issue by exchanging parts. One issue is indeed a 7.5m USB cable, which is twice of the official USB 2.0 high speed length, which is 3m. Therefore I would try a 3m cable and check, whether the issue continues.
    Best regards
    Stefan
    IC Imaging Control Support

  3. #3
    Join Date
    Aug 2012
    Posts
    6

    Re: Device Lost Exception Detected : USB 2.0 Cam DMK 31 AU03

    Hi Stefan,
    Thanks. Will try that. But this happens only in few machines. Not all. So, wanted to know if we are missing something else. Moreover, we have a need for longer cables. So, can Usb 3.0 cam meet this?. Else what is your advise? With any alternative like GigE, we must be able to select & configure cam with 1024x768 dynamically @ App boot-up. Please suggest best alternative.
    Thank you, Best Regards, nvs

  4. #4
    Join Date
    Jan 2003
    Location
    Bremen, Germany
    Posts
    4,886

    Re: Device Lost Exception Detected : USB 2.0 Cam DMK 31 AU03

    Hi Srinivass

    This happens randomly, because long cables generate these errors not reliable. External electrical disturbances can be responsible for this effect too. USB 3 has the same limitation of length for cables. The best way covering long distances is use of GigE camears.
    Best regards
    Stefan
    IC Imaging Control Support

  5. #5
    Join Date
    Aug 2012
    Posts
    6

    Re: Device Lost Exception Detected : USB 2.0 Cam DMK 31 AU03

    Hi Stefan,
    Once again, thank you for the info. We do not find the resolution of 1024 x 768 in the list of CCD GigE Monochrome camera. Can we configure a DMK33G445 GigE Camera Video output Resolution to 1024 x 768 dynamically from .NET code @ App boot up?

  6. #6
    Join Date
    Jan 2003
    Location
    Bremen, Germany
    Posts
    4,886

    Re: Device Lost Exception Detected : USB 2.0 Cam DMK 31 AU03

    Hi Srinivass

    from my list I see only 1280x960 offered as video format by DMK33G445 nothing else.
    Best regards
    Stefan
    IC Imaging Control Support

  7. #7
    Join Date
    Aug 2012
    Posts
    6

    Re: Device Lost Exception Detected : USB 2.0 Cam DMK 31 AU03

    Hi Stefan,
    Many thanks to you for the reply.

    So, can we still use 1280 x 960 CAM and center the Video showing only 1024 x 768 pix out of 1280 x 960? There is no Software zoom in the application but we need to CENTER the Image to align it to the Machine Center. If yes, please let us know if there is any example to do this in VB.net

    Thank you very much in advance
    Best Regards,

    NVS

  8. #8
    Join Date
    Jan 2003
    Location
    Bremen, Germany
    Posts
    4,886

    Re: Device Lost Exception Detected : USB 2.0 Cam DMK 31 AU03

    Hello

    If you need to clip the image, you may use the ROI filter for IC Imaging Control : https://www.theimagingsource.com/sup...dfilterROI.htm
    Best regards
    Stefan
    IC Imaging Control Support

  9. #9
    Join Date
    Jun 2017
    Posts
    2

    Re: Device Lost Exception Detected : USB 2.0 Cam DMK 31 AU03

    Hello

    We have "Device Lost" problem.
    We have multiple systems that use two or three gige cameras, the cameras and the PC are connected to a gige switch. Also a network cable is connected to that switch, to provide connection to our server.
    Some times in all of our system Device Lost exception happens.
    Please help.

Similar Threads

  1. "device lost" with IC Capture under Windows 8.1 64bits
    By desard C in forum Astronomy Cameras Support Forum
    Replies: 4
    Last Post: March 10, 2015, 20:31:03
  2. IC Capture error: Device lost (DMK 21AU04)
    By Richard in forum Astronomy Cameras Support Forum
    Replies: 1
    Last Post: March 21, 2012, 08:27:50
  3. Device lost problem
    By selvanathan in forum IC Imaging Control C++ Class Library
    Replies: 2
    Last Post: October 14, 2008, 04:05:34
  4. How to trigger device lost function
    By shankar_vizitec in forum IC Imaging Control C++ Class Library
    Replies: 3
    Last Post: September 5, 2008, 13:06:51
  5. Device Lost Problem
    By niranjan in forum IC Imaging Control ActiveX
    Replies: 1
    Last Post: June 13, 2008, 09:12:40

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •