Results 1 to 3 of 3

Thread: Skyris 618M USB 3.0 problem

  1. #1
    Join Date
    Mar 2016
    Czech Republic

    Exclamation Skyris 618M USB 3.0 problem

    I have got myself this USB 3.0 camera, updated the firmware to version 122 and start using it in my Linux astronomy application. I can get all the information from the camera (resolution, framerates, data format, controls), but most of the time it does not provide any image data. It simply hangs at ioctl VIDIOC_DQBUF. The camera is still connected, I can change it's settings, but not image. No signs in trace logs what could be wrong, not even from debug information of kernel module uvcvideo - last item is ioctl VIDIOC_DQBUF. I have tried it on three kernels (3.16.7, 4.1.15, 4.4.4) with same result. It doesn't matter how many V4L buffers I set (from 2 to 32) or what settings is use (exposure, gain, framerate, format), directly on USB 3.0 it rarely provides image data. I must close the camera, open it again and hope it will work this time. Sometimes 10 times in a row, which is annoying. And this problem also have other V4L applications (qv4l2, guvcview, oacapture). There are no issues on USB 2.0. Even if I use passive USB 2.0 hub connected to the USB 3.0 port = no problem. But directly on USB 3.0 = unpredictable behaviour. It's not a computer problem, same results on my notebook. If I boot into Windows and use iCap, it works perfectly.

    Could it be a firmware problem?

  2. #2
    Join Date
    Jan 2003
    Bremen, Germany

    Re: Skyris 618M USB 3.0 problem


    It could be a firmware problem.

    Please contact us at
    Best regards
    IC Imaging Control Support

  3. #3
    Join Date
    Mar 2016
    Czech Republic

    Re: Skyris 618M USB 3.0 problem

    Problem solved. The camera needed most recent firmware.

Similar Threads

  1. Using .NET control with Skyris cameras
    By Mike Tyrrell in forum IC Imaging Control .NET
    Replies: 1
    Last Post: February 22, 2016, 08:43:50
  2. iCap 2.3 and Skyris 132m camera image adjustment settings available
    By saguaro in forum Astronomy Cameras Support Forum
    Replies: 2
    Last Post: November 10, 2014, 14:47:41
  3. Need Help with iCap, Skyris 132C, and Celestron CPC Deluxe 925 HD
    By CaptainShark in forum Astronomy Cameras Support Forum
    Replies: 4
    Last Post: October 17, 2014, 03:32:57

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts