Results 1 to 4 of 4

Thread: Initiate auto focus on DFK AFU130-L53

  1. #1
    Join Date
    Jan 2015
    Posts
    11

    Initiate auto focus on DFK AFU130-L53

    Hi all,

    I am also trying to run auto focus - without much luck. I have the DFK AFU130-L53 camera, and am using the following code:

    Code:
    TIS.Imaging.VCDPropertyItem focusProperty = this.TISDeviceControl.VCDPropertyItems.FindItem(TIS.Imaging.VCDIDs.VCDID_Focus);
    TIS.Imaging.VCDButtonProperty autoFocusButton = (TIS.Imaging.VCDButtonProperty)focusProperty.Elements.FindInterface(TIS.Imaging.VCDIDs.VCDElement_OnePush + ":" + TIS.Imaging.VCDIDs.VCDInterface_Button);
    autoFocusButton.Push();
    This is similar code to this thread but I'm not 100% sure my property focusProperty is correct (although I'm not sure what else it could be). Is there anything obvious I'm doing wrong?

    Regards,

    Ben

  2. #2
    Join Date
    Jan 2003
    Location
    Bremen, Germany
    Posts
    4,862

    Re: Initiate auto focus on DFK AFU130-L53

    Hi Ben

    The auto focus works only, if you use resolution up to 1900x1600 pixels. These resolution have 30 fps speed. the higher resolutions of this camera model run with 1 fps only, therefore the auto focus is not working, respective it is running too slow.

    In case, you run with a 30 fps resolution: In the thread you point to is an answer showing a slightly different parameter set to access the one push auto focus. Please try this.
    Best regards
    Stefan
    IC Imaging Control Support

  3. #3
    Join Date
    Jan 2015
    Posts
    11

    Re: Initiate auto focus on DFK AFU130-L53

    Hi Stefan,

    Thanks for your reply. In regards to the thread I pointed to, I can't see any difference except that the code uses
    Code:
    this.m_focus
    But I don't know what that is referencing. I am indeed running at a high resolution - I will try adjusting that.

    Regards,

    Ben

  4. #4
    Join Date
    Jan 2015
    Posts
    11

    Re: Initiate auto focus on DFK AFU130-L53

    Hi Stefan,

    Thanks for your reply. In regards to the thread I pointed to, I can't see any difference except that the code uses
    Code:
    this.m_focus
    But I don't know what that is referencing. I am indeed running at a high resolution - I will try adjusting that.

    Regards,

    Ben

Similar Threads

  1. ICImagingControl doesn't detect my DFK AFU130-L53 USB Camera
    By czetsuya in forum IC Imaging Control .NET
    Replies: 3
    Last Post: September 25, 2014, 11:25:57
  2. directshow interface to control auto focus
    By srhfischer in forum IC Imaging Control C++ Class Library
    Replies: 3
    Last Post: July 15, 2013, 15:07:09
  3. Auto focus
    By fatman45 in forum IC Imaging Control ActiveX
    Replies: 2
    Last Post: November 20, 2012, 18:26:34
  4. Auto-Focus Camera Lens Requirement
    By niranjan in forum Hardware and Driver
    Replies: 1
    Last Post: May 30, 2012, 17:34:19
  5. Auto white balance, auto exposure processing?
    By odissey1 in forum IC Imaging Control ActiveX
    Replies: 3
    Last Post: November 17, 2006, 16:21:19

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •