Page 2 of 6 FirstFirst 1 2 3 4 ... LastLast
Results 16 to 30 of 77

Thread: trigger problem

  1. #16
    Join Date
    Jan 2003
    Location
    Bremen, Germany
    Posts
    4,898

    Re: trigger problem

    Hi

    I checked this on my own and it is working fine. I would like you to try IC Capture and see, whether you can trigger with IC Capture. This is to make sure, your hardware is working fine.
    IC Capture can be downloaded from http://www.theimagingsource.com/fr_F...ort/downloads/

    Also make sure, the trigger is connected correctly: inside +, outside -
    Best regards
    Stefan
    IC Imaging Control Support

  2. #17
    Join Date
    Apr 2013
    Posts
    43

    Re: trigger problem

    I do not really know how it works I tried to click the button and it blocks the image directly without I put trigger

  3. #18
    Join Date
    Jan 2003
    Location
    Bremen, Germany
    Posts
    4,898

    Re: trigger problem

    Did you debug your program code step by step, so you can be sure, that the correct branches are executed?
    The camera wont send any image data, if the trigger is enabled no trigger pulse occurs
    Best regards
    Stefan
    IC Imaging Control Support

  4. #19
    Join Date
    Apr 2013
    Posts
    43

    Re: trigger problem

    yes I have debug my program step by step
    I do not understand what you mean in your second sentence
    the image is not supposed to be frozen when I click on "Enable external trigger" and I do not apply the trigger
    is that you wanted to say?

  5. #20
    Join Date
    Apr 2013
    Posts
    43

    Re: trigger problem

    can you help me ?

  6. #21
    Join Date
    Jan 2003
    Location
    Bremen, Germany
    Posts
    4,898

    Re: trigger problem

    Sorry, there is an "and" missing in the second sentence.

    Enable trigger means calling
    IC_EnableTrigger(hGrabber,1);

    Now the camera should not provide an image, until an external trigger pulse (5V) occurs. You got it right, the live video is frozen.

    However, if you snapped image previously, the image ring buffer are still filled with these older images. These images can be saved to hard disc.
    Best regards
    Stefan
    IC Imaging Control Support

  7. #22
    Join Date
    Apr 2013
    Posts
    43

    Re: trigger problem

    ok but if the image is frozen there must be a problem, no ?

    would it not be because of that that its not working?

  8. #23
    Join Date
    Jan 2003
    Location
    Bremen, Germany
    Posts
    4,898

    Re: trigger problem

    No. If the waiting for trigger is enabled, the camera does not provide an image. The camera waits for the trigger and then one single image is sent.
    Best regards
    Stefan
    IC Imaging Control Support

  9. #24
    Join Date
    Apr 2013
    Posts
    43

    Re: trigger problem

    I will try
    but its rule not problem of my program :/

    EDIT : I've tried plugging a external signal (5V) nothing changed the image is frozen and I have no window that opens like when I click on "Save Image"
    Last edited by icemake; May 7, 2013 at 11:04:46.

  10. #25
    Join Date
    Jan 2003
    Location
    Bremen, Germany
    Posts
    4,898

    Re: trigger problem

    did you create a 5V pulse? The camera need a change, it reacts on the edge of signal
    Best regards
    Stefan
    IC Imaging Control Support

  11. #26
    Join Date
    Apr 2013
    Posts
    43

    Re: trigger problem

    yes, I created a 0-5V square wave signal with 2ms at high level and 8ms at low level

  12. #27
    Join Date
    Jan 2003
    Location
    Bremen, Germany
    Posts
    4,898

    Re: trigger problem

    That means, your trigger frequency is 10Hz. If the camera is running with a frame rate set above 10 Hz and a short enough exposure time, you should receive image with 10 Hz = 10 images per second.

    Does this happen?
    Best regards
    Stefan
    IC Imaging Control Support

  13. #28
    Join Date
    Apr 2013
    Posts
    43

    Re: trigger problem

    No, as soon as I click the trigger button, the picture freezes and does not change that there was an external signal or not

  14. #29
    Join Date
    Jan 2003
    Location
    Bremen, Germany
    Posts
    4,898

    Re: trigger problem

    Hello

    Does the same happen in IC Capture, if waiting for trigger is enabled?
    Best regards
    Stefan
    IC Imaging Control Support

  15. #30
    Join Date
    Apr 2013
    Posts
    43

    Re: trigger problem

    yes
    every test I've done since we've been in "page 2" I've done in IC capture

Page 2 of 6 FirstFirst 1 2 3 4 ... LastLast

Similar Threads

  1. Problem with external trigger
    By edparber in forum Hardware and Driver
    Replies: 1
    Last Post: October 15, 2012, 10:19:58
  2. About extern Trigger Problem!!!
    By yangping1220 in forum IC Imaging Control .NET
    Replies: 2
    Last Post: December 7, 2011, 01:33:18
  3. problem synchronizing two cameras with external trigger
    By LH2011 in forum Hardware and Driver
    Replies: 1
    Last Post: July 18, 2011, 16:21:25
  4. trigger not available
    By windman in forum IC Imaging Control .NET
    Replies: 4
    Last Post: May 24, 2010, 09:52:55

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •