Results 1 to 3 of 3

Thread: Deployment Using DeBayer Filter

  1. #1
    Join Date
    Jul 2005
    Location
    Vaughan, Ontario, Canada
    Posts
    16

    Question Deployment Using DeBayer Filter

    Hi guys,

    When deploying our application using the debayer filter, it has trouble loading the filter if strictly following the deployment instructions in the "IC Imaging Control Class Library User's Guide". I can assure you, I've followed them to a T (including the stdfilters.ftf file which is where the Debayer filter is loaded from).

    However, if we install the full control toolkit, and add the path [C:\Program Files\The Imaging Source Europe GmbH\IC Imaging Control 3.0\bin] to the system path in the environment variables, all seems to work.

    So my question is what file(s) is/are missing from those deployment instructions?

    I should note that if I don't use the debayer filter, I don't have this problem and the deployment guide works as is.

    Thanks,

    Jeff

  2. #2
    Join Date
    Jan 2003
    Location
    Bremen, Germany
    Posts
    4,898

    Re: Deployment Using DeBayer Filter

    Hi Jeff,

    Please use the tool "depends.exe" and check, whether you have all dependencies installed. The "stdfilters.ftf" needs the VC 2003 runtime files, which are "MSVCP71.DLL" an "MSVCR71.DLL". Usually these DLLs are located in the "Windows\System32" directory.
    Additionally the files "TIS_DSHOWLIB07_VC71.DLL" and "TIS_UDSHL07_VC71.DLL" are needed.

    If you create the filter, please do no pass the module name "stdfilter.ftf" to the create function call. Pass an empty string ("") instead. The "FTF" files will loaded automatically from the current working directory.
    Best regards
    Stefan
    IC Imaging Control Support

  3. #3
    Join Date
    Jul 2005
    Location
    Vaughan, Ontario, Canada
    Posts
    16

    Re: Deployment Using DeBayer Filter

    Thanks Stefan, that did it.

    Since I'm using VC2005, I didn't have TIS_UDSHL07_VC71.DLL included as that wasn't part of the VC2005 deployment instructions. You might want to add that in the next version of those instructions for us filter users.

    Thanks again.

    -Jeff

Similar Threads

  1. MotionDetection filter stops work after video size has been changed
    By saveug in forum MontiVision Development Kit
    Replies: 0
    Last Post: July 17, 2008, 04:20:29
  2. MV Recording filter options
    By brow0833 in forum MontiVision Development Kit
    Replies: 3
    Last Post: May 31, 2006, 20:32:16
  3. Filter Problem
    By Unregistered in forum IC Imaging Control C++ Class Library
    Replies: 2
    Last Post: May 19, 2006, 08:47:23
  4. Version 2.2 released!
    By Marc Cymontkowski in forum MontiVision Development Kit
    Replies: 0
    Last Post: August 6, 2004, 11:50:16
  5. Replies: 2
    Last Post: November 14, 2002, 10:21:07

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •