Results 1 to 2 of 2

Thread: Problem with Live View channel failing in LabVIEW

  1. #1
    Join Date
    Nov 2008
    Posts
    2

    Problem with Live View channel failing in LabVIEW

    I am developing a fairly large application in LabVIEW 8.6 and one element of the application uses the DFG/1394-1e analog-to-firewire converter to display a live view of a remote camera.

    Using the IC_RestoreState vi at the beginning of my program and the LiveStart invoke node property I am able to initiate a live view from the camera, which works as expected for a time.

    After some time (sometimes 5 minutes, sometimes 1 hour or more) the live video display will freeze. An image will still be displayed, but it is a static image and no longer updates to reflect the video from the camera.

    If I restart the video channel (by re-issuing the LiveStart invoke node command), the video returns to normal and works as expected for a time, before freezing again.

    Has anyone seen this kind of behavior before? And if so, is there a common cause?

    If there is no way to prevent the behavior, is there a method for polling the device to see whether it is responding as expected, so I can programmatically reset the device when it seizes up? Currently I poll the device for a serial number once per second to see if there has been a power failure, but this doesn't work for the image-freeze behavior as the device continues to report a serial number.

    Any insight would be appreciated.

  2. #2
    Join Date
    Jan 2003
    Location
    Bremen, Germany
    Posts
    4,841

    Re: Problem with Live View channel failing in LabVIEW

    Hello

    I would like to you to install IC Capture or use the Demoapp of IC Imaging Control and check, whether the converter shows the same behavior in these programs too. Please let me know the result.

    You can setup a "watchdog" using the IC Imaging Control's ImageAvailable event. This event is called for each incoming frame, if the property "LiveCaptureContinuous" has be set to true.

    If the converter does not receive any more data from the camera then usually a blue image with the text "INTERNAL ERROR" is shown. It is uncommon, that the image freezes.
    Best regards
    Stefan
    IC Imaging Control Support

Similar Threads

  1. Live Problem
    By afania in forum IC Imaging Control .NET
    Replies: 1
    Last Post: February 13, 2008, 08:19:38
  2. Live view screen freezing
    By BobWhite in forum Astronomy Cameras Support Forum
    Replies: 3
    Last Post: December 4, 2007, 14:22:30
  3. DFG/1394-1 and live image capture in LabView 8.2
    By gbugnard in forum IC Imaging Control ActiveX
    Replies: 3
    Last Post: August 31, 2007, 13:57:46
  4. Live Problem
    By afania in forum IC Imaging Control .NET
    Replies: 1
    Last Post: July 17, 2006, 10:09:18
  5. Labview Bitmap problem
    By Jatinder in forum IC Imaging Control .NET
    Replies: 6
    Last Post: February 25, 2005, 12:03:06

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •