Results 1 to 4 of 4

Thread: How to trigger device lost function

  1. #1
    Join Date
    Sep 2008
    Posts
    18

    How to trigger device lost function

    HAI THIS IS SHANKAR
    I NEED TO USE USE DEVICE LOST FUNTION IN MY PROGRAM AS LIKE FRAMEREADY I LIKE TO USE THIS DEVICELOST FUNCTION IN MY PROGRAM, EVEN TOUGH I REGISTER FOR THIS FUNCTION IN ADDLISTENER WITH PARAMETER eALL BUT THE FUNCTION IS NOT TRIGGERED WHEN I UNPLUG THE CAMERA .

  2. #2
    Join Date
    Jan 2003
    Location
    Bremen, Germany
    Posts
    4,861

    Re: How to trigger device lost function

    The DeviceLost function is a member of the GrabberListener class. You must inherit your own class from the GrabberListener class and implement the DeviceLost method.

    After doing so, you must add your GrabberListener inherited object to the grabber object using the method "Grabber::addListener()";

    Please refer to:
    http://www.imagingcontrol.com/en_US/...erListener.htm

    You may also have a look into the "Callback" sample of IC Imaging Control.
    Best regards
    Stefan
    IC Imaging Control Support

  3. #3
    Join Date
    Sep 2008
    Posts
    18

    frameready function working properly but not devicelost

    thank for to reply
    i follow all the above steps which u prescribe even tough i didnt trigger devicelost function.
    first i inherit my class(by name listener) to grabber listener and then i call addlistener function with listener class object and eALL as parameter, then i implement devicelost function to display warning message (using afxmessage box)


    :rolleyes: frameready function is workingproperly
    Last edited by shankar_vizitec; September 5, 2008 at 14:12:45.

  4. #4
    Join Date
    Jan 2003
    Location
    Bremen, Germany
    Posts
    4,861

    Re: How to trigger device lost function

    Hi,

    The parameter call seems to be correct. I guess, you use a DCAM camera or a video capture device, that really can be disconnected from the computer. If you use a PCI Framegrabber and an analogue camera and you removed the camera, then the framegrabber stays in the computer and works properly. Thus the "Device Lost" event is not fired.
    Best regards
    Stefan
    IC Imaging Control Support

Similar Threads

  1. Device Lost Problem
    By niranjan in forum IC Imaging Control ActiveX
    Replies: 1
    Last Post: June 13, 2008, 10:12:40
  2. Max. FPS in external trigger mode
    By cagati in forum IC Imaging Control .NET
    Replies: 5
    Last Post: July 12, 2007, 10:45:48
  3. Function for changing serial no of device name
    By ray@frontier in forum IC Imaging Control C++ Class Library
    Replies: 1
    Last Post: December 21, 2006, 09:19:16
  4. Trigger Source
    By Unregistered in forum MontiVision Development Kit
    Replies: 1
    Last Post: April 21, 2005, 10:27:08
  5. device trigger cable
    By Ole Jakobsen in forum IC Imaging Control ActiveX
    Replies: 3
    Last Post: October 14, 2003, 08:28:02

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •