PDA

View Full Version : An Error with device



Unregistered
December 11, 2002, 22:12:13
I'm trying to test your control, so I ran Visual Basic 6.0 with your projects under Windows 2000 and I get the following error message:

"No device opened. Please open one to operate".

What do I have to do?

Thanks


This message was originally posted by Rick in the old IC Imaging Control Support Forum.

Unregistered
December 12, 2002, 09:01:38
Rick,

If you have opened one of the sample projects that have no device settings dialog (like "Capture an AVI" file) , you can select a video capture device in the VB6 IDE. Open the form, that contains the ICImagingControl. In most cases, the samples only contain one form. Make sure that the "Properties" window is visible in your VB6 IDE. Click on the ICImagingControl in the form and you will see it's properties in the VB6 "Properties" window. Search for the property "Device". In this property you can insert a video capture device.

Best regards
Stefan
IC Support


This message was originally posted by IC Support in the old IC Imaging Control Support Forum.

Unregistered
December 12, 2002, 14:09:42
Dear Stefan:

I did as you said, but the device property seems to be "locked" in VB 6 and there is no drop down list as it is show in your help files pictures. Am I missing something? What is a "device" supposed to be in this case?


Thanks.

Rick.


This message was originally posted by Rick in the old IC Imaging Control Support Forum.

Unregistered
December 12, 2002, 16:57:35
Hi Rick,

The device should be a video capture device that has a WDM driver. For example a USB Camera, a DCAM, the Video to 1394 Converter (DFG1394/1) or our Firewire Camera (DFK 21F04).

Best regards
Stefan
IC Support


This message was originally posted by IC Support in the old IC Imaging Control Support Forum.