PDA

View Full Version : Sony 1394 camera whit balance



Unregistered
November 25, 2002, 19:04:12
How do I set the white balance to Sony cameras? I notice that when setting white balance, one always needs to set White Balance (R) and White Balance (B) separately. There is no API in the IC Imaging Control to do that.

Thanks!


This message was originally posted by Yi Ren in the old IC Imaging Control Support Forum.

Unregistered
November 25, 2002, 19:19:06
Hello,

You need the DCAM Add-On for IC Imaging Control. The Add-On provides access to the special white balance features.

The Add-On can be downloaded from our web server:

http://www.imagingcontrol.com/ic/downloads/sony_firewire_addon/

Best regards
Johannes
IC Support


This message was originally posted by IC Support in the old IC Imaging Control Support Forum.

Unregistered
December 4, 2002, 18:04:21
I got the sony add-on header file "SonyFCam_Custom.h", but when using the property functions in the grabber class to set the R/B white balance, the functions expect a parametrer with type "enum tagCameraControlProperty" instead of a constant. Since the R/B white balance defination for Sony is defined as constant, I got a comipler error. Do I miss something here ?


This message was originally posted by Yi in the old IC Imaging Control Support Forum.

Unregistered
December 5, 2002, 17:47:32
Hello,

The header file "SonyFCam_Custom.h" is not part of the DCAM Add-On for IC. This header file is only needed if you access the drvier directly. Please checkout the "Sony DCAM DemoApp" that is installed by the Add-On installation. This demo shows how to use the special Add-On functions (i.e. white balance red ) with IC.

best regards
Johannes
IC Support


This message was originally posted by IC Support in the old IC Imaging Control Support Forum.