PDA

View Full Version : Licensing with .NET Deployment



Unregistered
November 8, 2002, 01:00:47
We are deploying your control in a .NET application, thus we are not using the VB6 Packaging and Deployment wizard.

When I install all of the requiired files and register the 2 files that need it I get a "You are not licensed for this control" error at runtime in a demo app. I looked for a required license.licx file but could not find it in the install. This is on a fresh XP install.

Do I have the demo version polluting my purchased version or do I need to add a registry entry somewhere?

adam hill...


This message was originally posted by Adam HIll in the old IC Imaging Control Support Forum.

Unregistered
November 8, 2002, 05:24:16
Dear Mr. Adam, i' also trying to figure out how to deploy this application in .NET

Can you please care to share the code with me. If the code is very big, i can give you my company e-mail address.


This message was originally posted by jacob in the old IC Imaging Control Support Forum.

Unregistered
November 8, 2002, 15:28:31
Mr Hill can you please help me?


This message was originally posted by Jacob in the old IC Imaging Control Support Forum.

Unregistered
November 11, 2002, 18:47:34
Hello,

Please refer to:

http://www.imagingcontrol.com/ic/support/forum/read.php?f=2&i=538&t=527

for more information

Best regards
Johannes
IC Support


This message was originally posted by IC Support in the old IC Imaging Control Support Forum.

Unregistered
November 12, 2002, 13:25:00
Hello,

We did a very simple VB.NET program that uses the IC OCX and created a setup project in VisualStudio.NET. You have to add the required IC DLLs and the YUV transform filter explicitly to the setup project ( please refer to "Distributing your application" in the IC VB help for detailes). If you run this setup more than one time on your development system, you will get several error messages from VisualStudio.
If you test the installtion on a different system, everthing works fine.

Please sent your setup (as a zip file) to:

support@imagingcontrol.com

for further investigation.

Best regards
Johannes
IC Support


This message was originally posted by IC Support in the old IC Imaging Control Support Forum.