PDA

View Full Version : Sony DFW-X700 @UYVY 640x480



Unregistered
September 3, 2002, 13:39:02
Imaging Control 1.3
Windows 2000 SP2
Sony DFW-X700 camera
Sony Add-On drivers installed

Hello,

I am using the Sony DFW-X700 camera with the Sony DCam demoapp (ClassLib) and when I try to set the camera resolution to UYVY 640x480 with the 'Set Window Size = ImageSize checkbox' unchecked the live video turns black. When the stop video button is pressed and a popup containing ;

" the timeout passed to snapimages(...) did elapse before all images could be snapped"

The demoapp then hangs.


Could you please tell me what I need to do in Sony demoapp (ClassLib) to get the UYVY 640x480 resolution working.

Many thanks


This message was originally posted by Chris Elam in the old IC Imaging Control Support Forum.

Unregistered
September 5, 2002, 13:48:35
Hello Chris,

The Sony DCam driver does not deliver frames, if the frame rate is set to a not accepted value for the camera. For example, the camera supports frame rates up to 30 Hz, but the default value is set to 66 Hz. In this case, no frames are delivered.
To solve this problem, select the camera in the device settings. Before starting the live preview, open the image settings dialog and select a matching frame rate for the camera. After you have done this, you can start the preview.

The demoapp hangs because the YUV Transformfilter waits for a frame, that will not come. Please see "known issues" at http://www.imagingcontrol.com/ic/docs/issues/
point nine.

Best regards
Stefan
IC Support


This message was originally posted by Stefan in the old IC Imaging Control Support Forum.