PDA

View Full Version : DFK 33UX246 gstreamer errors



bedocoman
September 8, 2017, 10:58:54
Hi

Running Linux Mint Debian Edition 2 and I keep getting errors when specifying height/width arguements.

user1@viewer1 ~ $ gst-launch-1.0 tcamsrc serial=XXXXXXXX ! video/x-raw,width=1920,height=1080,framerate=30/1 ! videoconvert
Setting pipeline to PAUSED ...
Pipeline is live and does not need PREROLL ...
Setting pipeline to PLAYING ...
New clock: GstSystemClock
ERROR: from element /GstPipeline:pipeline0/GstTcamSrc:tcamsrc0: Internal data flow error.
Additional debug info:
gstbasesrc.c(2933): gst_base_src_loop (): /GstPipeline:pipeline0/GstTcamSrc:tcamsrc0:
streaming task paused, reason not-linked (-1)
Execution ended after 0:00:00.219494546
Setting pipeline to PAUSED ...
Setting pipeline to READY ...
Setting pipeline to NULL ...
Freeing pipeline ...

I've tried quite a few different commands, specifying format etc. They always fail when I specify a resolution. All resolutions work in V4L2 test branch and Guvcview.

Stefan Geissler
September 11, 2017, 16:29:03
Hi

I tried the pipeline
gst-launch-1.0 tcamsrc serial=<serial>! video/x-raw,width=1920,height=1080,framerate=30/1 ! videoconvert ! ximagesink

with my DFK 33UX264 and it works fine on my computer.

I wonder, whether you use the lastest version from the github.

Also you may try
gst-launch-1.0 tcambin serial=<serial>! video/x-raw,width=1920,height=1080,framerate=30/1 ! videoconvert ! ximagesink

and see, what happens.