PDA

View Full Version : Labview: MemorySnapImage Timeout after Focus One Push - IC_ImageActiveBuffer_IMAQ.vi



DavidBoswell
June 16, 2016, 20:05:08
My setup uses a DFK AFU050-L34 over USB along with another device on USB.

I am using IC_ImageActiveBuffer_IMAQ.vi. The place inside this sub-vi where the camera freezes is MemorySnapImage.

MemorySnapImage times out after certain Labview USB commands are made to the other device then focus one push is called for the camera. Other times the focus and grab work fine.

When I send the Labview USB command to the device and do not use focus one push it reliably grabs the image.

I can see that the Video Live Feed is frozen. If I wave my hand in front of the camera the video unfreezes and grabs images.

It is as if the camera is in standby mode and the movement in the FOV of the camera re-establishes connection. This is like an external wakeup over USB.

The only way I have found to programmatically recover from this camera state is to open and close the camera and not use the conditions that caused the timeout.

Any help or suggestions with this problem are welcome.

Using this camera on USB is desired.

David

Stefan Geissler
June 17, 2016, 09:02:16
Hello

Two questions:
1.) How does the scene look like you focus on?
2.) Do you set the Sharpness property? If yes, to which value?
3.) Can you reproduce the stopping stream with IC Capture? (LabVIEW is hard to debug for me.)

Background: If the scene becomes too complex and is amplified by sharpness, then the JPEG compression in the camera generates too big images which can not be transferred in time with the set frame rate.

If this is the case in your situation, I would like you to create a request at
http://www.theimagingsource.com/company/contact/

DavidBoswell
June 28, 2016, 00:56:52
Stephan,

First I'd like to say this is a nifty little camera. I am quite impressed by your products and even more by the support!

One observation is that the camera looks like it tries to focus and continue streaming. A possible firmware or ActiveX conflict?

Information to answer the questions:

1.) The image is a 100 X 60 mm LCD touchscreen. The camera is 120 mm away. When there is just a simple color screen the camera goes into a inactive mode shortly after I run an ActiveX "one push" focus.
2.) Sharpness is at maximum (8).
3.) The camera stopping is consistent with the color only screens. If there is a lot of complexity like my hand moving in front of the camera there is no freeze after focus.

More on ActiveX - I am only able to use ActiveX through labview for this project.
The provided Labview Device Setup example I see that the "one push" focus is called within the Device Properties method.
I am wondering since I am programatically focusing it might not be playing fair with the image live stream.

Focus takes some time and an image can be grabbed before focus which is an interesting firmware behavior. This suggests no suspend, lock or pause of the image streaming. I've tried pausing livestream with the ActiveX methods in Labview and that has no effect.

Could calling the "one push" focus be conflicting with the image stream that the USB communication times out or is suspended?

My Labview "one push" focus.
1860

Thanks,

David