PDA

View Full Version : Skyris 618M USB 3.0 problem



grytom
March 11, 2016, 10:36:52
Hello,
I have got myself this USB 3.0 camera, updated the firmware to version 122 and start using it in my Linux astronomy application. I can get all the information from the camera (resolution, framerates, data format, controls), but most of the time it does not provide any image data. It simply hangs at ioctl VIDIOC_DQBUF. The camera is still connected, I can change it's settings, but not image. No signs in trace logs what could be wrong, not even from debug information of kernel module uvcvideo - last item is ioctl VIDIOC_DQBUF. I have tried it on three kernels (3.16.7, 4.1.15, 4.4.4) with same result. It doesn't matter how many V4L buffers I set (from 2 to 32) or what settings is use (exposure, gain, framerate, format), directly on USB 3.0 it rarely provides image data. I must close the camera, open it again and hope it will work this time. Sometimes 10 times in a row, which is annoying. And this problem also have other V4L applications (qv4l2, guvcview, oacapture). There are no issues on USB 2.0. Even if I use passive USB 2.0 hub connected to the USB 3.0 port = no problem. But directly on USB 3.0 = unpredictable behaviour. It's not a computer problem, same results on my notebook. If I boot into Windows and use iCap, it works perfectly.

Could it be a firmware problem?

Stefan Geissler
March 11, 2016, 13:44:00
Hello

It could be a firmware problem.

Please contact us at http://www.theimagingsource.com/en_US/company/contact/

grytom
March 11, 2016, 16:55:37
Problem solved. The camera needed most recent firmware.