PDA

View Full Version : Problems with TIS Barcode SDK in LabVIEW



BenCW
June 4, 2015, 13:22:19
I recently downloaded the TIS Barcode SDK and plan to use it in LabVIEW (using .NET) to read some barcodes, but I'm having trouble getting it to do anything at all.

First thing I tried was launching the included example exe with a DFK ECU010-M12 camera connected. I pointed the camera to some big, clear barcode printouts (Code39 and DataMatix ) and nothing happened. Next, I made bmps of the barcodes, loaded them into the example exe and nothing happened (see image below).

1782

For the example, I did ensure CODE_39 and DATAMATRIX options were checked.



I came to the conclusion (possibly incorrectly?) that the example exe just didn't work, so built a test in LabVIEW instead, based on the example in the help files.

1783

I am expecting to output the content of the barcode(s) in the array, but nothing.
See attached zip file for my demo code and images:
1784

Does anyone know where I'm going wrong?

Stefan Geissler
June 4, 2015, 16:15:48
Hi

we will have a look by next week on this.

But with RGB32 PNG this will work

BenCW
June 5, 2015, 09:02:57
Hi Stefan

Thanks for replying, that will be great thanks!

I tried re-formatting the images as 32-bit PNG but still no luck.

BenCW
June 12, 2015, 13:19:49
Hi Stefan

Have you managed to have a look at this yet?

Ben

Stefan Geissler
June 12, 2015, 14:55:10
I am very sorry, but we had no time currently. The programmers are bound to other projects and it is always bad to take them out of current work.