PDA

View Full Version : DMK 21AU04.AS LabVIEW IC_Grab_IMAQ Problem



jwj08
July 1, 2014, 17:19:32
Hello,

I have a DMK 21AU04.AS camera, and I am trying to use LabVIEW for data acquisition. I can successfully connect the camera and see/acquire images in IC Capture, so I know the computer sees the camera. I have LabVIEW 2013 with the Vision Development Module installed.

I have tried the getting started page (http://www.imagingcontrol.com/en_US/support/documentation/iclabviewextension/gettingstarted.htm), and I can successfully connect to the camera and acquire/grab images using the LabVIEW picture format. The problem comes when I try to use the IC_Grab_IMAQ vi. Whenever this VI is inserted and wired following the directions, LabVIEW crashes. Also, if I run the example VI IMAQ Image Example, labVIEWcrashes when I go to grab a frame. There are no crashes with the LabVIEW Picture Example.

The end goal of what I want to do is to grab one image and sum all of the pixels in the image, store that number in some kind of array, and then grab the next image. I do not need to save any images. I think using the Vision VI Quantify would work best, so I would like to acquire the images as an IMAQ image if possible.

Any advice on what I can try to do?
Thanks.

Stefan Geissler
July 2, 2014, 13:02:15
Unfortunately "LabVIEW crashes" is no helpful error message. Is there any more information available?

Does this happen, when only one frame is grabbed? Or does this happen after many frame have been grabbed?

Stefan Geissler
July 3, 2014, 15:23:06
As wet get deeper into this by email, we found out, you use LabVIEW 64 bit. This is currently completely untested. I just wonder, why you were able to use IC_GrabPicture in your VIs, since this references to a 32bit DLL. This should not work too in LabVIEW 64 bit