PDA

View Full Version : Camera Freezes



padu
May 16, 2014, 01:06:53
Hello,

I have been using a DMK 23U618 and lately I can't seem to use it with USB 3.0 anymore. It used to work fine under IC Capture 2.3 in my machine, but now it works (goes live) for about 5-30 seconds and then the image freezes.

If I try to close and restart the device (or even IC Capture) I get the following error message:

1698

I need to disconnect and reconnect the camera to make the problem go away. Of course if I re-plug the camera to the same port the problem keeps happening. I have 2 USB 3.0 ports and the problem happens on both ports.

If I plug the camera to a USB 2.0 port, then it runs fine (at half FPS).

After combing the forums, I've downloaded and installed the Processor Iddle State Manager 2.2 (I have no idea what that program does, would someone please explain?) It still doesn't help.


The only thing that changed from a couple of months ago to now is windows updates. I have a Dell XPS i7-3770S @ 3.1GHz, 8GB RAM and Windows 8.1 Pro 64-bit.


I also tested the color version of the same sensor and same problem happens.


Please help

Stefan Geissler
May 16, 2014, 18:01:09
Which USB 3.0 controller does your computer use?

What happens, if you lower the frame rate, after the error message came?

Does the DELL support say anything about USB 3.0 performance?

padu
May 16, 2014, 18:24:51
I'm not entirely sure, but I think it is a TI controller. On device manager I have the two following entries:

- Intel USB 3.0 eXtensible Host Controller - 0100 (Microsoft)
- Texas Instruments USB 3.0 eXtensible Host Controller - 0096 (Microsoft)

Changing the FPS to 60 doesn't help.

I don't think it's hardware related (driver maybe), since it was working fine a month or so ago.


We developed a golf kiosk and started selling it last month. We have approximately 20 systems out. In a lesser scale, we are seeing this issue more and more where the camera intermittently just stops working. It comes back to work when you reconnect the USB cable, but since the kiosk is a big enclosure that includes the camera, the user has no access to cables, which demands a full reboot.

It's becoming a very critical problem for us.

Cheers

Stefan Geissler
May 19, 2014, 16:28:27
Dear Padu

I would like you to go in contact directly with us, so I can check the production database, firmware version etc.

Please generate a support case http://www.imagingcontrol.com/en_US/support/case/

Also, you should try to update the drivers of your USB 3.0 controllers.