PDA

View Full Version : Problem DFM 22BUC03-ML with Linux driver



dmigliore
September 12, 2013, 09:41:43
Dear Imaging source team,

I have a problem under Linux when I use the firmware dfk22uc03_135.euvc (for color images).
The other compatible firmware, dmk22uc03_145.euv (monochromatic), has no problem and the camera acquires images correctly.

I followed the instruction reported here:
https://code.google.com/p/tiscamera/wiki/GettingStartedCMOSUVC

but when I use mplayer with the device, I have a black screen as result.

In Linux dmesg I have the following answer when I plug the camera with dfk firmware:
[ 6377.045358] usb 1-1: Product: DFx 22BUC03
[ 6377.045360] usb 1-1: Manufacturer: The Imaging Source Europe GmbH
[ 6377.045361] usb 1-1: SerialNumber: 10210110
[ 6377.048052] uvcvideo: Unknown video format 47425247-0000-0010-8000-00aa00389b71
[ 6377.048061] uvcvideo: Found UVC 1.00 device DFx 22BUC03 (199e:8302)
[ 6377.339754] input: DFx 22BUC03 as /devices/pci0000:00/0000:00:11.0/0000:02:03.0/usb1/1-1/1-1:1.0/input/input6

We tried also the examples based on gstreamer and python, but nothing.

Moreover we tried also to install unicap, but without success.

Do you have any suggestions or a contact of someone who solved the issue?

Best regards,
Davide Migliore - Evidence srl

Stefan Geissler
September 12, 2013, 10:00:36
I am very sorry, but right now, I can not provide support in the forum. I would like you to create a support case at http://www.imagingcontrol.com/en_US/support/case/ It will be forwarded to our Linux engineer.