View Full Version : LabVIEW 2012 / 2013 support for frame grabber?

August 6, 2013, 10:58:54
Please can you tell me which versions of LabVIEW and windows are known to work with the drivers for the DFG/MC4/PCIe frame grabber? Currently I've tried it with LV2012 and LV2013 and both are giving blue screens. It works ok in the PC when LV is not installed.
LV is 32 bit; OS is Win 7 64 bit.
Intel DQ77MK (I think) ******board with up-to-date bios etc.

August 8, 2013, 14:25:16
I've started doing some testing. It works ok with LV 2010 and NI-daqmx 9.5.1
It does not work with LV2010 and Ni-daqmx 9.7.0 (blue screen on booting if the card is installed)
It does not work with LV2013 and Ni-daqmx 9.7.5 (blue screen on booting if the card is installed)
It does not work with LV2012 and NI-daqmx 9.5.5. (9.5.5. is required for LV2012 according to NI) (blue screen on booting if the card is installed)

It may work with LV2011 and NI-daqmx 9.5.1 . But this is not a long-term solution as I also need to access features of later versions of LabVIEW.

Please can anyone say whether the driver will be updated to work with NI-daqmx version 9.5.5 and later?

Stefan Geissler
August 26, 2013, 15:39:06
First of all, please excuse the delay of my answer.

Secondly, I never used the frame grabbers with LabVIEW IMAQ. I just wonder, whether National Instruments software supports them at all.

You may try the IC Imaging Control LabVIEW extension and the DirectShow driver for the DFG/MC4. This should work in LabVIEW. Both can be downloaded from http://www.theimagingsource.com/en_US/support/downloads/

January 13, 2014, 21:12:12
The issue I have is that the computer will not even boot up once the imaging control driver for the DFG/MC4 is installed, if NI nidaqmx is installed beyond version 9.5.1 !

It's not that I can't use it in labview, it's that the computer will not boot at all!

Please can you say whether the imaging control driver can be updated? It would be great to have a composite video grabber board that works with labview.

Stefan Geissler
January 14, 2014, 10:41:12

The crash of the driver if NI software is installed is now known. We have a new driver, which is not released, but I can send it to you, if you create a support request at http://www.imagingcontrol.com/en_US/support/case/

January 14, 2014, 12:15:43
That is fantastic. Thanks. I will create a request. I'm very keen to test the new version.

January 15, 2014, 16:55:10
I've installed the beta driver, the labview extension and IC capture on a computer with a fresh install of Win 7 64 bit, Labview 2013, ni-daq 9.8.0, vision development and vision acquisition.
The computer boots up ok, and I can run IC capture. I've not tried the labview extension yet.