PDA

View Full Version : IC Imaging Control Grap IMAQ Failed



mike liu
February 22, 2013, 04:33:54
Hi,

I am using the Labview 2010SP1 for capture the pictures which the device name is DFx 41BU02, a USB CCD camera.

I fount two problems,

1. When I open the software at the first time it can't get back the pictures, I must open the camera by IC Capture, then when I open the software again, it can get back the pictures, how can I fix this problems.

2. When I try to get back the pictures, it can't get back the pictures, but sometimes it will hang at IC_Grap_IMAQ.vi, and the software can't be stoped, I have to restart the computer then it can run, but it will happen again.

Is there someone have the same problems, could you pleased to tell me how to fix them.

Stefan Geissler
February 25, 2013, 10:41:32
Hi


1. When I open the software at the first time it can't get back the pictures, I must open the camera by IC Capture, then when I open the software again, it can get back the pictures, how can I fix this problems.

I guess, you did not configure the camera in your LabVIEW software. So you may use use the "SetupDevice.vi" sample or the "RestoreDevice.vi" for opening the camera.


2. When I try to get back the pictures, it can't get back the pictures, but sometimes it will hang at IC_Grap_IMAQ.vi, and the software can't be stoped, I have to restart the computer then it can run, but it will happen again.

The "IC_GrabIMAQ" creates a new image each time it is called. This means, the created image must be deleted by your application, when it is no longer needer, otherwise the computer will run out of memory.