PDA

View Full Version : Compatibility issues with Windows Embedded Standard 7 (WES7)



GMGZ9
January 4, 2012, 01:50:00
Environment information>
Camera; DMM 72buc02-ML
Software loaded from CD>
Driver Date: 5/3/11; Version= 2.1.5.616
Imaging Control V3.2 for V++ 2010

All works on desktop Windows7 or Windows-XP. The intended target for development is using WES7. The Driver shows up in the Windows Device Manager with the above driver data. When I try to run the IC capture utility it takes forever to find the device. Then when it shows up and is selected I get a weird message box warning. "Error: Live mode could not be started. Please make sure no other program uses the device and there is enough bandwidth on your firewire bus available." The same hardware and CD work on a desktop. On the WES7 target, the IC Capture utility will hang and not close. Using the task manager doesn't help. I downloaded newer software from your website associated with this camera.
IC Capture ver= 2.2.315.1235
Driver Data. Date 11/28/11; Ver= 2.2.11.681
I get same message box error, but the IC Capture utility does close when selected. I tried compiling some of the Sample code. Used "Advanced Imaging Processing" sample. Build was OK. When attempted to run, the select device takes a long time, then hangs. It took down VS2010.

The WES7 install used was from a template build. It was the 64bit application compatible template. Should be most compatible to desktop Windows.

Can anybody HELP?

Stefan Geissler
January 4, 2012, 08:46:19
Hello,

The error message says, the live video could not have been started. This can have several reasons, e.g. a missing DLL or missing DirectShow filters. Unfortunately, you do not get more detailed information by Windows. You may try the IC Imaging Control Sample Demo Application on this PC. It provides a little different error message, which may gives some more detail.

Also you may have a look on this Microsoft web page: http://msdn.microsoft.com/en-us/library/dd377592%28VS.85%29.aspx
It is a Microsoft Windows setup problem, what you encounter.

GMGZ9
January 5, 2012, 03:48:12
I tried the C# Sample, demoapp. It built OK. It ran & allowed to select the device, but it took a long time to find the device. When I clicked the triangle button to run, I got an error message box. Details are:
************** Exception Text **************
TIS.Imaging.ICException: Unknown error occurred
Unknown error occurred
Base Library Error : An unexpected DShowLibException occured: Error = Failed to start the graph. Due to : No such interface supported

In file : "FilterGraph.cpp" at line : 307


at TIS.Imaging.ICImagingControl.LiveStart()
at demoapp.Form1.StartLiveVideo() in C:\Users\IAR2\Documents\IC Imaging Control 3.2\samples\C# 2010\demoapp\demoapp\Form1.cs:line 253
at demoapp.Form1.toolStrip1_ItemClicked(Object sender, ToolStripItemClickedEventArgs e) in C:\Users\IAR2\Documents\IC Imaging Control 3.2\samples\C# 2010\demoapp\demoapp\Form1.cs:line 220
at System.Windows.Forms.ToolStrip.HandleItemClick(Too lStripItem dismissingItem)
at System.Windows.Forms.ToolStripItem.HandleClick(Eve ntArgs e)
at System.Windows.Forms.ToolStripItem.HandleMouseUp(M ouseEventArgs e)
at System.Windows.Forms.ToolStrip.OnMouseUp(MouseEven tArgs mea)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ToolStrip.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

I'm not sure if this tells me any more than I knew before. The WES7 uses Direct-X11. Are there known problems with this version of embedded?

Stefan Geissler
January 5, 2012, 10:39:07
Hi,

it seems, there is something missing on your Windows 7 embedded. I am very sorry, but I do not have any experiences with building embedded Windows, therefore, you may ask Microsoft about how to add the full DirectShow support. (DirectShow is not the same as DirectX)

GMGZ9
January 6, 2012, 02:46:49
Stefan,

I went to the MSDN link you provided for Building DirectShow Applications. The page has a list of components associated with Win-XP. I did a compare of the contents of the Windows7 following directories:
windows
windows\System32
windows\System32\drivers
from the MSDN list I was missing 23 components, but this page is associated with Win-XP.
I understand that your compatibility listing doesn't include WES7, but our selection of this camera was based on Windows7 compatibility. We have put a lot of development time into our project. One of your software engineers should know what components are required. I would be glad to send you the listings of these directories, if one of your engineers would be so kind as to tell me what is missing in Windows7. I am also posting an issue with Microsoft. Any help that is available would be appreciated.
Thanks,
George

Stefan Geissler
January 6, 2012, 08:18:04
Hello George,

Your issue is Operating System, not camera related. I am sure, Microsoft has a similar list of components for Windows 7. I also know about customers, who used Windows 7 embedded successfully.

Please keep in mind, some of the DLLs listed on the website I posted are COM components. They must be registered by a call to "regsvr32". "qedit.dll" is such a DLL. I suppose "quartz.dll" too.

As far as I know, you have a program with many checkboxes for the modules you want to use in your Windows 7 embedded. Did you try to check all of them?

Did you ask the Microsoft support?

(this is an edit test)

Nick666
November 11, 2013, 14:06:18
Hello everyone,

this is an quite old post but I ran into the same problem like the author. I tried to get the demo-soft (e.g. IC capture) working under WES7 with the same problems described above.

I then found out that all the required DirectShow stuff is installed once you add the "mediacenter" feature-pack in your Image Composite Editor (ICE). With this, the TIS-Software runs as intended!

Hope this may help,
Nick

ottelo
June 29, 2016, 07:15:49
Hi there. I had the same problem with an IPC from Siemens and preinstalled Windows 7 Embedded (E). I addded the package "Media Center" like Nick666 recommended but this didnt solve the problem. So I decided to add ALL driver with the tool DISMUI to my windows. After a reboot the camera works :). I have found out, that only one missing driver was the fault:

Microsoft Streaming Filter (ksfilter.inf)

AND all the DirectShow stuff isnt in the MediaCenter module but in this package:

Audio and Video Engines and Media Foundation ID: x86~winemb-av-core~~~~6.1.7601.17514

and that package was installed! The only problem was the missing driver. Now everything works perfect.