PDA

View Full Version : Need alternatives to Process ISM



eplumer
October 31, 2011, 15:56:38
Hello all,

I am using DMK41 with a Toshiba R835 Laptop (i5 processor, 6Gb Ram, USB 3 port, Windows 7 Home Premium x64, 2.1.5 version of TIS drivers). I have been having the dreaded "Camera does not deliver images" message. I don't see corrupted frames but the frame-rate often falls off. My real problem is that, when this message occurs, either on initial connect or after a few minutes of streaming, nothing seems to fix the problem short of rebooting and even that is not always a success. I have never been able to get the camera back by unplugging the USB connection.

After reading posts here, I tried the Process Idle State Manager. That does seem to cause a marked improvement in behavior! This implies that CPU idle states are probably the root cause, though I am unsure why this causes no images at all to be received. As you might imagine, when I use this utiltity, my power usage goes from 10W to 60W. Since this setup is supposed to be for portable, battery powered astronomy, this is a bit of a show-stopper.

Does anyone have suggestions for alternate workarounds or other machine configuration I can try to improve camera connectivity? I don't really mind missed frames or slower frame-rate since I "stack" and average frames anyway. I just need the camera to reliably deliver _some_ images.


Sincerely,

Edward Plumer
Georgetown, TX

Stefan Geissler
October 31, 2011, 17:16:04
Hello

First of all, the Processor Idle State Manager prevents the CPU from going into C3 sleeping state. This C3 state can cause interrupted image data transfer, when the USB controller asks for new commands to handle and the CPU needs to wake up. If the C3 state is disabled, then the CPU consumes more power. (BTW: This is the first time, somebody posted a value of the more consume, thank you for this.)
I am not sure, whether there is an effect using the Processor Idle State Manager on USB 3.0 interfaces. As you write, there is no effect. Therefore, I would like to point to the USB cable, which often is a source of frame drops caused by bad connectivity. If possible, please try another USB cable.

eplumer
October 31, 2011, 19:07:22
Stefan, Thank you for you reply. Some followup:

- Toshiba add-on utilities included some "eco utilities" to help manage power consumption. One part of this is a realtime trend plot of power consumption. As soon as PISM runs, power spikes up and holds at the higher level.

- The USB port on the computer supports USB 3 but I am sure is running as USB 2 in this situation.

- I am pretty convinced the PISM had an effect. Last night (when trying to do some actual imaging, of course) I found the frequency of dropped connection getting worse until I was unable to attach camera at all. At this point, I experimented with a handful of cables from different manufacturers with no luck. I also re-installed the latest TIS drivers from the website; no change. I then noticed the PISM and tried it. Camera sprung to life. Disabled PISM, camera would not attach.

- For completeness, I also tested the same cables and camera on another laptop with older Intel architecture. Camera attaches robustly on that laptop ... not very useful to me because that laptop runs hot ALL of the time and only lasts a bit over an hour. In anycase, sure seems like the issue is in the laptop.

- I have seen a number of posts reporting dropped frames; have any others reported this complete loss of images?

Thank you for any other thoughts on other things to try.

Best Regards,

Edward

eplumer
November 1, 2011, 03:54:25
Stefan,

Well, tonight camera is connecting without need for PISM. Not a consistent problem apparently.

Edward

Stefan Geissler
November 1, 2011, 15:18:13
Edward,

ok then.

eplumer
November 2, 2011, 03:17:53
Stefan,

Back to square one. Left computer running with camera and it steadily delivered 15fps.
After about and hour, the camera quit delivering images.
Running PISM did not help this time so perhaps it was a coincidence last time.

Any other ideas about what could cause the problem other than C3 state and what I might try?

Edward

Stefan Geissler
November 2, 2011, 09:56:02
Hi Edward,

I would like to know, whether the camera is completely disconnected, when you encounter the no images delivered problem.
The camera needs the full 500mA provided by the USB bus at 5V. If the USB cable resistor is too big, the power consumption rases, because the voltage goes down. In case there is not enough power on the USB bus, the camera will shut down. It is listed as "Unknown Device" in the Windows Device Manager and IC Capture should report a "Device Lost" error.
In case you only receive the "... does not provide images..." error message, the camera is still correctly connected to the computer and available. But the camera driver detected too many incomplete frames, which have been dropped, so the IC Capture frame watch dog fired his alert.

In case, the problem occurs again, you may open the Windows Device Manager and look for the camera. If it is not listed, it shut down.

How do you power your laptop and the camera?

I am very sorry for asking so much questions, but I must try to narrow down the problem.

eplumer
November 3, 2011, 02:29:22
I found two other power settings that I wondered if they were relevant:

PCI Express
Link State Power Management
On battery: Maximum power savings

USB settings
USB selective suspend setting
On batter: Enabled

Not sure these would have an effect on the driver, but thought I would ask.

Also, I tested the "sleep" on the computer by setting the timeout to 1min and letting the machine sleep.
I then woke it up and found the camera still collecting frames without problem

eplumer
November 3, 2011, 04:45:58
Stefan, I thought I posted a reply with answers to your questions but I don't see it ...

Anyway, I just ran the camera on AC power and it froze after about 1.5 to 2hr into the test as usual.
After it froze, I went to the devices control panel and found my camera listed with status "This device is working properly" both for the "Imaging devices" and "Universal Serial Bus controllers" entries.

I then unplugged it and replug it in ... I noticed that I didn't hear the usual beep/boop noises the computer usually makes as it reports devices attaching and unattaching.

In fact, what is very suspicious is that after unplugging the camera again and leaving it unplugged, the DMx41AU02.AS device entry remains listed in the "Devices and Printers" control panel and the "Device Manager" utility and both report that the device is working correctly!?

This acts like the device can't detach so it can't reattach w/o a reboot ??? Does this mean anything to you?

eplumer
November 3, 2011, 04:49:02
In regards to your other questions, which I really appreciate, I am running the camera attached directly to the laptop via a 6ft Belkin cable. Normally, I would use a powered USB hub, but keeping it simple for these tests.

The laptop is usually battery powered, but the last test was on AC adapter.

I have ensured that "sleep" does not kick in unexpectedly.

Regards, Edward

eplumer
November 3, 2011, 14:17:54
One final test last night: camera running with PISM left on from the beginning and laptop plugged in to AC. Ran without failure for 9hrs. So perhaps PISM prevents the problem but has no effect on recovering from problem once it happens.

Edward

Stefan Geissler
November 3, 2011, 14:23:19
Edward,

if the laptop runs on battery, make sure, it does not save too much power :-)