PDA

View Full Version : checking if any progress on getting TIS cameras working with maxim DL for stills



gboyle
July 14, 2011, 23:57:25
i would like to use my DFK/DMK's on my windows machines using maxim DL in both video mode and still's capture mode.
has the driver been released that will allow this - ie the stills part- to happen?
currently in my drop down i only get the Video DS option for the DMK and when this is chosen the exposure time control does not work.

the ascom driver that was available through user groups does not appear to be downloadable now.

it would be great to have some kind of driver to allow this to happen as other similar cameras appear to have this ability.

thank you

(the reason i wish to use maxim is that it will interact with focusmax. Using the DMK and focusmax/Maxim I can get very tight focus with my automatic focuser which should allow for better planetary imaging)

Schnaejel
July 21, 2011, 23:32:07
Please try it with the latest beta of my ascom driver. Working with subframes does actually not work.

http://www.deepsky-online.com/download/TISAstroCam V2.0beta Setup.exe
This releases was tested with Windows 7 64 Bit and Windows XP 32 Bit. The ASCOM 5.5 release was used.
Kind regards,
Gerrit

Schnaejel
July 21, 2011, 23:33:07
Also the driver was tested with maxim dl V4.63 and maxim dl 5.07. Further guiding can be done with PHDGuiding.

It is an early release that are provide here for free. Hope it works for you. But do not blame me if not.
The driver is developed for free in my spare time.

Kind regards,

Gerrit

gboyle
July 22, 2011, 20:33:23
Thank you for supplying the driver - this is very generous of you.
However when i install the driver, restart the machine and try to connect the camera the following happens:
i can see "ASCOM camera" and in the camera chooser window I can now see "TIS camera ...2.0"
but when i press "properties" there is no properties window (i expected to see the camera properties in size of pizel and number of pixels as happens for the simulator selection)
when i press "connect" i get the message:
"TIS Astrocam V2.0
could not load file or assembly'TIS.Imaging.ICImagingcontrol32,
Version=3.2.2.986, Culture=neutral,
PublicKeyToken=257805929e8b7928' or one of its dependencies. The
system cannot find the file specified"

followed by the error message:
"Error opening camera
the camera link has failed"

can you advise is this a problem at my end, or with the beta driver? are there separate 32 and 64 bit drivers maybe?
i am using maxim 5.15
windows 7 64bit (home premium)
and DMK 31AU03.AS camera

thanks
gavin

Schnaejel
July 23, 2011, 01:33:50
Hi,

thank you! It seems that the Imaging Control is not installed correctly.

I will have a look at this. Further:
Just select the driver, but do not click on the properties button.
Just click connect.

But since the driver fails, there is an error that I have to fix in the installation
routine.

Kind regards,

Gerrit

Schnaejel
July 23, 2011, 01:36:50
Hint: What dialog appears behind the properties button is up to the driver. Not all properties dialogs do show the same information.
You have to select the camera after you push the connect button. The pixel size will be saved correctly in the fits header information
of an image.

Schnaejel
July 23, 2011, 01:49:06
Hint 2: Try to start Maxim DL as Administrator (right click). Kind regards

gboyle
July 23, 2011, 16:15:48
thanks for the replies.
i have tried clicking connect first off without asking for preferences and i have also tried running maxim as administrator, but the problem persists i am afraid.
i'll await your guidance once you have looked at Image Control.

thanks
gavin

Schnaejel
July 25, 2011, 14:15:58
Hi Gavin,

i analyzed the installation routine. There were some issues providing the imaging control in the global assembly cache.

I fixed this issues and suggest you to download the installation package again.
Here are some steps to proceed:
1. Download the latest driver (now)
2. Run the setup routine as administrator
3. Start Maxim DL as administrator
4. Select the ASCOM Driver platform in Maxim DL
5. Select the TIS-Driver from the ASCOM Dialog
6. Return to the camera dialog and try to connect
-> A dialog should appear to select your camera model
7. Select your camera model

If some issues occure, please provide me your camera model, too.

Thanks for your support.

Kind regards,

Gerrit

Schnaejel
August 16, 2011, 11:17:31
Please continue the discussion here
http://www.theimagingsourceforums.com/showthread.php?323983-Home-of-the-TIS-Ascom-Driver-is-updated

gboyle
August 16, 2011, 23:12:28
Really sorry to have to come back on this one.
have just retruned from travel so this is my first chance to use the new driver.
unfortunately when i try to run the install package as administrator it says that the file is currupted and rebooting the machine and retrying results in the same result.
my camera model is DMK31AU03.AS, using windows 7 64bit, maximDL V5.15

hoping for a simple solution...!
Gavin

Schnaejel
August 17, 2011, 14:27:31
Hi, i tested the installation routine on win7 again, and it works. please try to download the installation routine again.
perhaps something went wrong during the download. kind regards, Gerrit

gboyle
August 18, 2011, 23:37:03
looking at the error messages i was getting and having a trawl of my files i found that maxim DL was looking for the .TIS_UDS...vc9.dll file and this file was not installed in the maxim folder - the vc10.dll file was there.
so i went to one of the other directories (for phd or ImageCapture) and copied the missing vc9.dll file over to the maximDL folder - so now both the vc9.dll and the vc10.dll file are in the maxim drive.
the camera is now seen and connects and it looks to work properly.
hope this helps anyone who has the same issue,
gavin
(before i leave this one is there anything wrong with maxim calling the vc9.dll file instead of teh vc10.dll file?

Stefan Geissler
August 19, 2011, 10:47:04
Hello

The difference between those files is the Visual Studio C++ runtime version and the version of the IC Imaging Control .NET componet. If your Maxim DL wants the VC9 dlls, then you use IC Imaging Control 3.1. The newer version 3.2 uses the VC10 DLLs. Therefore there may is something mixed up on your computer and MaximDL insists on using the 3.1 version.
However, there is no problem having all versions of the .NET component (3.0, 3.1 and 3.2) installed simultaneously. Usually the programs know, which version to use.

Schnaejel
August 19, 2011, 17:25:40
Hi Stefan,

The installation routine for the ASCOM Driver provides the following components (on win32):
11.01.2011 17:00 419.328 TIS.Imaging.ICImagingControl32.dll
11.01.2011 17:00 730.112 TIS_DShowLib09.dll
11.01.2011 17:00 762.368 TIS_UDSHL09_vc9.dll

And it works. So what about the vc10.dll?

@all: Can we seperate the two issues in the discussion? Maxim DL does provide its own support for the DMK cameras while the ascom way is another.
I do not have the latest Maxim DL because Maxim D 5.07 does work well for me.

And buying each ASCOM client to test the driver is not my intent.

CS
Gerrit

Stefan Geissler
August 22, 2011, 10:45:26
Gerrit,

you are right. My version 3.2.2.1017 uses the vc9 version too. I thought, it uses the vc 10 version. I am very sorry for confusing this.

Stefan Geissler
August 22, 2011, 10:47:01
Gerrit,

one addition:
32 bit uses the vc9 version,
64 bit .NET 2 the vc9 and
64 bit .NET 4 the vc10.