PDA

View Full Version : SubVI'IC_GRAB_IMAQ.vi': SubVI not executable



ccdlab
March 18, 2011, 14:20:46
Hi,
I tried to run the sample programme "Property.vi" and also the other sample programmes. But it doesn't executable because there are some errors e.g. "SubVI'IC_GRAB_IMAQ.vi': SubVI not executable". Unfortunately I didn't find something helpful in the forum.
I work with the FireWire CCD Monochrome Camera DMK 21AF04 and I have installed IC Imaging Control 3, LabVIEW Extension 2 and IC Imaging Control SDK that comes along with the CD.
I'm looking forward for an answer,
thanks,
carol

Stefan Geissler
March 18, 2011, 15:18:37
Hello,

Unfortunatelly NI changed the search of DLLs, thus it does not longer search in the "user.lib" directory of your LabVIEW installation too. Therefore it tries to find the DLL in "C:\Programme\National Instruments\LabVIEW 7.0" which even on my computer no longer exitst. You must change the DLL path in the IC_Grab*.VI on your own to your path.

I am very sorry, but I have no idea to get rid of this problem, which was invented by NI with LabVIEW 2009.

MareSloCam
May 23, 2011, 09:11:57
Hello,

I got the same error and the solution was quite easy for me.

I changed the DDL path to my directory of LabVIEW 2010.

In my case:
From: C:\Programme\National Instruments\LabVIEW 7.0

To: C:\Program Files\National Instruments\LabVIEW 2010\user.lib
In the user.lib folder there is a IC LabVIEW Extension 2.dll file. I think this is the right file because it works fine in my case.

So you should have the same path depends on your LabVIEW version.

If this topic would not be open I would not find the solution for me.

Thank you guys.

Best regards,
Marko

Stefan Geissler
May 23, 2011, 09:24:14
The solution is correct for the single user. But my problem is to have a more general solution for all users. This means, I have to check, where LabVIEW is installed and change the VI due to the setup, which is not possible or find a way to change the path to the DLL in the VI while it is executed.