PDA

View Full Version : Error when use C# API with .net framework v4.0



arda
October 6, 2010, 06:11:43
Hi all
I got a error message when i used the C# control API with .net framework v4.0.
Here is the error message:

Error 1 'Mixed mode assembly is built against version 'v2.0.50727' of the runtime and cannot be loaded in the 4.0 runtime without additional configuration information.'

I want to know how to fix the problem.
Thanks.
Arda.F

Stefan Geissler
October 6, 2010, 14:33:57
Hello Arda,

you may fix the problem by setting the target frame work of your solution to version 2. If this is not possible, you may create a support case at http://www.imagingcontrol.com/en_US/support/case/

Littlejenny
October 15, 2010, 06:28:58
You need to make sure all of these match:

1. Main project Properties - Compile Tab - Advanced Compile Options - Target Framework

2. Deployment Project Properties - Prerequisites - Correct framework checked.

3. Right-click on Deployment project - View - Launch Conditions. In the Launch condition tab, right-click the .Net Framework Launch condition, then show Properties Window. In the Properties Window, make sure that the Version property is the correct Framework.

If these are all set to the same framework, it 'should' work....

Hoping this helps...

_______________________________________________

Software Development (http://www.softwareoutsourcing.biz/services/software-development.html)