PDA

View Full Version : DMK 31AU03.AS artifacts



shadowdoc31
September 20, 2010, 19:00:47
Greetings all,

I've recently encountered some artifacts with my Imaging Source
DMK 31AU03.AS camera. Image links (Flickr) are as follows:


http://www.flickr.com/photos/8995460@N04/5009145752/sizes/o/in/photostream/

http://www.flickr.com/photos/8995460@N04/5008539749/sizes/o/in/photostream/

http://www.flickr.com/photos/8995460@N04/5009145854/sizes/o/in/photostream/

More details: all the image pairs linked above are from the
SAME file, with no obvious change in hardware, software, etc. during
the recording run. Error typically switches back to "normal", after spoiling
a part of the AVI.

- Problems started with my new laptop, and Alienware M15x/Core i7
(running on wall power). After looking at some of the posts here,
preliminary guess is that the problemm is related to the USB bus in some
way but other than that I'm not sure on specifics.

One other curious thing-- I'm always guiding the telescope during my
image recording, but these artifacts seem to be in the recorded file only;
I don't recall seeing them on the screen.

Has anyone else encountered this? Any suggestions for things to try?
(*other than going back to my old computer, which is short on drive
space!). If it will help solve the problem, I can potentially post the actual
AVI files themselfes.

Thanks in advance,

Ronald Waters

Stefan Geissler
September 21, 2010, 09:45:20
Hello

From our experience, the effect is caused by CPU power saving mechnism.

Modern CPUs have extensive power saving options which are in use, if the CPU load is low. If the CPU starts power saving, then the busses eSATA, FireWire and USB are slowed down too. Unfortunately the camera keeps sending the image data blocks with full speed, thus it is to be expected, that data blocks are missed and not saved in memory. Right now we have no good solution for this problem, we can make some suggestions only:
Maybe the BIOS allows to disable the C-State change. In the American Megatrends BIOS this can be found at „Advanced BIOS Settings“-“CPU Features“. There is a „SpeedStep“ and an „Inten ® C-STATE tech“ setting, which can be disabled. If you do so, the computer will run with full power all the time.
Alternatively it is possible to generate CPU load with a program like „cpustress“. This avoids the CPU changing the C-States and power options.
If Windows XP is in use, then you may try the program „SpeedSwitchXP“ (http://www.diefer.de/speedswitchxp/index.html) and disable the promote and demote of C-States. Maybe this helps for USB cameras too, we are not sure about this.
However, these hints are related to Intel CPUs. We have no experiences with AMD CPUs.

Some links, that are related to the same problem, but with different hardware:
http://www.eggheadcafe.com/software/aspnet/36145838/usb-stich-influences-firewire-throughput.aspx
http://forums.m-audio.com/showthread.php?19536-intermittent-fuzzy-input-win7-delta-66

shadowdoc31
September 21, 2010, 12:55:21
Thanks for your input. A few other pieces of information:

- Intel Core i7 CPU
- Windows 7 / 64-bit edition
- I guide the entire image stream during exposure, and I'm
100% sure that this problem is with the save file only; I never
see it in the "live view" during a specific run
- I tried changing the power save setting to 50% minimum CPU
state, but this did not eliminate the error
- I've also tried "RAM capture" (Lucam recorder) but that didn't
eliminate the problem either

Stefan Geissler
September 21, 2010, 13:32:23
The problem can not be solved by software. The problem can not be with saved files only. Because what you see is, what happens if a data block of the image is missing. The following blocks are moved up.

shadowdoc31
September 30, 2010, 12:47:25
Some followup:

- I downloaded the program 'Prime95' and ran it in the background while
performing image capture. I also ran 'CPU-Z' and verified that the CPU
multiplier stayed locked while this program was running.

- This approach --so far-- seems to have corrected the artifact issues
previously discussed

- However, I still don't quite understand why this can't be programmed
around, either at the software or driver level. E.g., the windows operating
system manages to write to virtual memory ("swap file") essentially
constantly while most computers are in operation, WITHOUT data blocks
being dropped (i.e. this would corrupt the swap file).

In any case, I have a workaround for the time being and I appreciate your
assistance in identifying/fixing the problem.

Thanks again,

RW

Stefan Geissler
September 30, 2010, 14:27:25
Hello RW,

The USB CCD camera driver can detect the holes and drops the frame. That means, the frame rate is slowed down. For the FireWire cameras, or driver is not involved in the image data transfer. This is done by the FireWire board itself via DMA. Our driver is only notified, after the FireWire board has a frae transfer completed. Our driver wont get any error message.
Also you can not compare hard disc with the camera, because the hard disc is able to resend a datablock, because it has own memory. The camera has no own memory, thus it is not possible to resend a data block, if the DMA controller failed to write one.

I will check the programs you mentioned on my laptops.

Stefan Geissler
September 30, 2010, 14:40:12
Hello

Prime 95 does the same as a cpustress program. This seems to prevent the CPU from going into C3 states. If so, the data transfer is no longer blocked.

We are still working on this issue.

Stefan Geissler
October 1, 2010, 11:01:44
Hello,

For Windows 7 users we have released a new FireWire Performance Manager (its also for USB), that can fix frame drop problems and also can fix damaged frames. Please download the FireWire Performanc Manager from http://www.imagingcontrol.com/en_US/downloads/tools/.