PDA

View Full Version : Having trouble with a vb user control



bradle95
March 16, 2010, 13:56:36
Hello, I am having trouble with a vb user control. I am getting a message, "Failed to query type library, Please reinstall the SDK" when trying to run an app with a user control which contains the ICImagingControl. I saw a couple posts on this, but I am not doing something correctly.

http://www.theimagingsourceforums.com/showthread.php?t=319530
http://www.theimagingsourceforums.com/showthread.php?p=25940

Is there a sample app that I could look at to see how to use an ICImagingControl within a user control? Thanks.

Scott

Stefan Geissler
March 17, 2010, 11:17:14
Hi Scott,

First of all, I would like to know, whether you can place the IC component on a form without problems.

Secondly, writing user controls using IC Imaging Control 3.1 is much easier than using 3.0. If you do not have IC 3.1, please create a support case for a free update at http://www.imagingcontrol.com/en_US/support/case/

bradle95
March 17, 2010, 12:34:19
Stefan,

No it does not appear to be limited to using the ImagingControl inside a module or to using V3.0.6. I downloaded the trial version 3.1 and it did not help. I compiled your %\IC Imaging Control 3.1\samples VB 2008\demoapp\DemoApp.sln project in "Any CPU", "x86", and "x64" configurations and none of them ran on the computer in question. This is a 64bit Vista Ultimate computer with the .NET Framework 3.5 loaded. There is another computer that the same issue is being seen and I will give that a try as soon as my coworker gets in this morning.

Scott

bradle95
March 17, 2010, 13:48:24
No luck on the other computer either, it is a 32bit Win7.

bradle95
March 27, 2010, 14:08:11
The problem was on my end, not Imaging Source's. I missed some required dependencies.