PDA

View Full Version : How to reduce CPU usage time while using USB camera



sethupathy
August 10, 2009, 14:07:03
Hi,
I am using High Speed processor with “DFX 31AU03” Model Camera, resolution is 1024x768 Video format is Y800 and FPS 30. This time CPU usage is touching 100%. When am I using fire wire card camera with same system CPU usage is Less than 28%.
What should I do for this type of complexity? is there any problem will occur while I am using the same USB camera.

Thanks and Regards
Sethu

Stefan Geissler
August 10, 2009, 15:06:15
Hi,

The USB bus needs some more CPU load than FireWire. This is caused by the USB architecture. If the CPU load is too high, then you will receive frame drops.

sethupathy
August 11, 2009, 06:04:57
Hi Stefan,

Good Morning,

i declare 30FPS. If camera will miss some frames means,how many frames may loss on that time.


Thanks and Regards
Sethu

Stefan Geissler
August 11, 2009, 09:14:45
Hi Sethu,

It is very hard to make a statement about frame drops, if the used computer and software are unknown. At least, the frame drop is not predicatable. I am very sorry for not having a better answer.

Altonjohn329
March 24, 2010, 08:55:45
You should take a look at the other threads, I think the toggle to show threads is in the debug menu of visual studio. "[In a sleep, wait, or join" means that the thread can't do anything because it's waiting on another thread to complete it's operation.

then we changed form:


calendarStoryboard.Begin(txtMessage, HandoffBehavior.Compose, true);

to


calendarStoryboard.Begin(txtMessage, HandoffBehavior.SnapshotAndReplace, true);

this issue was fixed. the more information about HandoffBehavior please refer to msdn:

http://msdn.microsoft.com/en-us/library/system.windows.media.animation.handoffbehavior.asp x

maxellwill
October 5, 2010, 13:52:49
The webcam is a bit odd for power usage. What I found – and your results may vary – is that it won’t draw any significant power if you don’t use it. If you use it, it’ll draw about 2W. If you then turn it off, it doesn’t seem to entirely ‘turn off’; it keeps drawing about 600mW. Explicitly disabling it in Device Manager seems to turn it off properly.