PDA

View Full Version : Which version of c++



Beginner
August 17, 2008, 18:46:59
Hello with a basic question:
What version of c++ do I need to run the samples and here is discussed about (I lost the thread after Visual Studio 6)

Sascha Schmidt
August 18, 2008, 12:14:48
Hallo,

Welcome to the forum!

IC Imaging Control comes with samples for VC6, VC7 and VC8.
When using VC9, the samples will be automatically converted by Visual Studio 9.

dogu
April 13, 2009, 17:16:29
I see this thread is a little old, but I too am trying to get the sample apps
working under vs2008. It does not seem to be as simple as Sascha suggests.
I did the conversion, but the compiler complains about the compiler version
being wrong. Got around that by putting UDSHL_LIB_NO_COMPILER_CHECK
into my preprocessor defs. Then it can't find MSVCP80.dll and MSVCR80.dll.
Tried adding those manually, but that results in a runtime error.

Is VS2008 (vc9) supported? If so how?

thanks for any replies...

Stefan Geissler
April 14, 2009, 12:53:22
There is a service pack for IC Imaging Control 3.0 and C++ available: http://www.imagingcontrol.com/en_US/downloads/servicepacks/
Installing this service pack allows to use VS 2008 C++.