PDA

View Full Version : DFG/1394-1e Needs Driver Reinstalled



Kay
December 4, 2006, 16:14:00
Hi,

I have noticed that the following 2 issues with the Firewire device.

1 - If the device is unplugged from the Firewire port, sometimes the device needs to be reinstalled. This does not happen all the time. It seems to be unique to some DFG/1394-1e devices. Is this a firmware version issue.

2 - If a device is moved from one computer to another, the Install wizard for the Firewire device pops up wanting to install the drivers again.

Any help with this is appreciated.

Thanks,

Kay

Stefan Geissler
December 4, 2006, 16:34:43
Hello Kay,


1 - If the device is unplugged from the Firewire port, sometimes the device needs to be reinstalled. This does not happen all the time. It seems to be unique to some DFG/1394-1e devices. Is this a firmware version issue.

Very strange, because nearly all off DFG/1394-1e have the same firmware. Also the DFG/1394-1e has no influence on the used operating system. Thus I can not explain why Windows removes the driver. What makes you think it is a problem of the firmware?


2 - If a device is moved from one computer to another, the Install wizard for the Firewire device pops up wanting to install the drivers again.

Windows differs between the devices using the serial number. Thus each unit of DFG/1394-1e is a new device for Windows. Since the driver is not digitally signed by MS, automatic reinstallation of the will not work. I have written a small software that runs in background and installs the driver automatically if it is not already installed. If you want to use this software (its for free) please send a request to support@imagingcontrol.com.