PDA

View Full Version : LabVIEW 8 and IC Imaging control 3



biophotonicslab
September 22, 2006, 19:10:10
Hi,
I have installed IC Imaging Control 3 and the LabVIEW Extension 2 that comes along with the CD. My programs had been working just fine with the IC Imaging Control vi integrated into my programs. Now everytime I try to run my programs, I get a LabVIEW error that says "Error 97 occurred at Unknown System Error...Possible Reason(s) LabVIEW: Null Refnum was passed in as an input." The error then directs me to the ICImagingControl .vi in the block diagram. When I right click on the vi and say "Find Control" or "Show Control," it shows "Control could not be loaded" on the front panel where the ICImagingControl box is.

The same thing occurs when I try to run an example .vi included in the LabVIEW Extension 2.0 installation from the CD, such as "Device Setup Example" which used to allow me to configure the camera settings.

I have tried reinstalling Labview 8.0, installing the latest drivers for my firewire camera (ImagingSource DFK31BF03), and reinstalling the LabVIEW Extension 2.0 as well as IC ImageCapture 3.0. I'm using Windows XP Professional.

Please help me in anyway possible, as my research here depends on this issue getting resolved.

Thank you,
Michael

Stefan Geissler
September 25, 2006, 11:21:46
Hello Michael,

Did you change your LabVIEW version? I am not sure, whether IC runs with LabVIEW 8 or higher.

biophotonicslab
September 25, 2006, 17:04:44
I haven't changed the LabVIEW version but I am certain it runs with LabVIEW 8.0 because I had been using it for months with this version of LabVIEW.

Stefan Geissler
September 25, 2006, 17:28:05
Michael,

I would like you to perform the "Getting Started" from the IC LabView extension to see, whether you are able to import the ActiveX component of IC Imaging Control. The documentation can be found through the Windows start menu.

Gleeson
October 2, 2006, 22:51:39
Hi,
I am having the exact problem that Michael described. I used the unistall command to remove the extension, but after doing this the IC.ICImagingcontrol3 Class option still appears in
tools:.Net & ActiveX:Add ActiveX controls to palette in Labview, and returns a cannot locate file error when selected. It appears that the .ctl file has been moved, or corrupted and is not being removed with the uninstall command and subsequently is not being included when the extension is reinstalled. Does anyone have any suggestions no how to fix this?
Thanks,
Dave

Gleeson
October 2, 2006, 22:53:40
Hi,
I am having the exact problem that Michael described. I used the unistall command to remove the extension, but after doing this the IC.ICImagingcontrol3 Class option still appears in
tools:.Net & ActiveX:Add ActiveX controls to palette in Labview, and returns "an error has occured " when selected. It appears that the .ctl file has been moved, or corrupted and is not being removed with the uninstall command and subsequently is not being included when the extension is reinstalled. Does anyone have any suggestions no how to fix this?
Thanks,
Dave

Stefan Geissler
October 6, 2006, 14:24:16
Hello,

I suggest to delete the \program files\labview\user.lib\ic.imagingcontrol.ctl file. Then you may change in the "Program files\common files\IC Imaging Control 3" directory and enter in the DOS prompt "regsvr32 ICImagingControl.ocx".
After doing so you can start LabView and import the ICImagingControl.ocx again as described in the "getting started".

pschmal
September 8, 2009, 23:11:04
Hello,

I suggest to delete the \program files\labview\user.lib\ic.imagingcontrol.ctl file. Then you may change in the "Program files\common files\IC Imaging Control 3" directory and enter in the DOS prompt "regsvr32 ICImagingControl.ocx".
After doing so you can start LabView and import the ICImagingControl.ocx again as described in the "getting started".

Hello,

I am having the same problem as the original post. I tried to follow your advice. ic.imagingcontrol.ctl is wrapped up in a llb file but I can still delete it through labview. common files/IC Imaging Control 3 does not exist after installation of drivers. The ocx file does not exist anywhere.

When I do fresh install IC.imagingcontrol 3.ctl shows up on its own in LabVIEW without adding it as ActiveX control, but has same error as previous poster. Is there a solution?

As an aside, if I install any of the viewing program trials I can get images from the frame grabber.

Kind Regards,
Paul

Stefan Geissler
September 9, 2009, 09:23:09
Paul,

The IC Imaging Control ActiveX, that is used in the IC Imaging Control LabVIEW Extension, is not installed. I guess, you did not install the IC Imaging Control SDK, so the essential runtime files, e.g. the ActiveX are not installed. Please install the IC Imaging Control SDK from the CD ROM, that came with your camera. The Visual Basic 6 components should be suitable.

pschmal
September 10, 2009, 14:42:11
Stefan,

Thanks for your help. I thought I had installed the SDK but this was apparently not the case.

Stefan Geissler
September 11, 2009, 10:02:11
We plan to add the ActiveX installation to the IC LabVIEW installation, so the SDK installation is no longer necessary.

coodtec
September 11, 2009, 21:17:52
Hi Stefan,

I just downloaded IC LabVIEW Extension and installed it.

But seem IC Labview Extension did not support Labview 2009, some DLL and VI are missing.

What I should do to make Labview extension support Labview 2009?
My hardware: Frame Grabbers (PCI)

Thanks

John

Stefan Geissler
September 14, 2009, 09:18:48
Hi John,

The extension is compatible to LabVIEW 2009, at least it worked fine in my LabVIEW 2009 installation.

As for Pschmal: Did you install the IC Imaging Control SDK too? It installs the ActiveX component used by the IC Imaging Control LabVIEW Extension.

coodtec
September 14, 2009, 16:27:07
As for Pschmal: Did you install the IC Imaging Control SDK too? It installs the ActiveX component used by the IC Imaging Control LabVIEW Extension.


Hi Stefan,

When I received my Grabbers, did not receive CD.
They emailed me FTP download Link with software key (IC Imaging Control and IC Capture) only. And ask me download LabVIEW Driver from
http://www.theimagingsource.com/en_US/products/grabbers/dfgsv1lp/

So How did I get IC Imaging Control SDK, need ask them mail one CD to me?:question:


Thanks,

John

Stefan Geissler
September 14, 2009, 16:53:33
Please contact me here: http://www.imagingcontrol.com/en_US/support/case/