PDA

View Full Version : prb: MemorySnapImage times out although there is a trigger signal



Unregistered
October 10, 2005, 16:55:33
We have the following problem:

The same source code and the same cable which triggers an image with a Sony 1394-Camera (about 3 years old) fails with a new BFWCAMVF-1394-Camera. MemorySnapImage times out and gives error number 27: "the timeout passed to snapImages( ... ) did elapse before all images could be snaped [sic]".
The used control is of version 1.4.

Is there a difference in how to trigger and obtain an image between those two types of cameras?

Thanks in advance for your help,

Sascha

Stefan Geissler
October 10, 2005, 17:56:41
Hello Sascha,

No, there is no difference. Does the come up very fast or does the time out comes in the expected time? Also why is the camera name BFWCAMVF...? What is the camera type?

sklim
October 10, 2005, 18:54:47
Dear Stefan,

thanks for your fast reply.

Yes, the timout occurs exactly when it should, indicating to me that the trigger event doesn't come up.
The camera is one of yours, and the driver is labeled like that: BFWCAMVF

I have to wait until tomorow, then I can take a look at the Lieferschein to get the exact camera model.

Sascha

sklim
October 11, 2005, 10:32:03
The Lieferschein says: "OEM-Version der DFK 21BF04"

Sascha

Stefan Geissler
October 11, 2005, 10:47:19
Hello,

Please check, whether the voltage is correct for the trigger signal. For a specification please see here:
http://www.1394imaging.com/en/resources/files/dxxxxbfxxtrigio.en.pdf