PDA

View Full Version : missing some properties (ContrastRange, ...)



bradboyce
March 6, 2003, 03:35:36
I'm using a Dell Latitude Notebook, XP, and DFW-X700 Sony camera.

When I try to use some of the properties of the ICImagingControl I get the error message: "The called function is not available with the current device."

It seems, I can not use certain properties. Missing in action are: ExposureRange, ContrastRange, and GammaRange. But working fine are: SharpnessRange, BrightnessRange, and others.

Iím thinking this has something to do with another problem Iíve noticed:
When I go into the Device Manager under Imaging devices I see "Generic 1394 Desktop Camera #4" (Used to say #1, #2, ...) When I try to update the driver by forcing it to go get the Sonyfcam.inf driver then the name changes to "Sony ..." with a yellow Exclamation ! mark. Then it reverts to the "Generic 1394 Desk..." setting.

I have a W2K installation that is running the same code without complaint, but it shows the correct driver. (Although even that computer shows some tendency to want to revert to other drivers.)

Stefan Geissler
March 6, 2003, 10:07:30
Before installing the original Sony driver, there must be a .bat excuted, that comes with the Sony driver. The .bat job is named setup_SonyWDM+TWAIN.bat. It does some registering and copying.
You can check in the driver details, whether the sonyfcam.sys is used for you Sony DCam.

bradboyce
March 6, 2003, 12:21:56
Careful attention to detail during the installation solved the problem. Aparently, I had not removed the camera from operation during the running of the .bat file.

Sorry to have bothered you.